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Chapter 1 • What are eBooks? 

RICHARD ADAMS 

What are They? What are They? 

eBooks are electronic books that are designed to be read on 

tablets, eReaders, and laptop and desktop computers. Similar to 

web pages, eBooks are written with the eXtensible Hypertext 

Markup Language (XHTML), styled with Cascading Style 

Sheets (CSS), and can interact with readers via JavaScript. 

Depending upon the format, they can contain photos, videos, 

animations, and a variety of other media. 

eBooks can be read on various devices. Low-cost, lightweight, 

black-and-white devices are referred to as eReaders, such as 

Amazon’s Kindle, Kobo’s Aura, and Barnes & Noble’s Nook. 

eBooks can also be read on iPads with eReader apps like Apple’s 

iBooks and on Android tablets with apps from Amazon, Kobo, 

Barnes & Noble, and other vendors. 
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Table 1.1. Advantages and Disadvantages of 
eBooks 

Advantages Disadvantages 

1. Usually low 
in cost 

2. Weight is 
that of the 
tablet or 
eReader 

3. Can fit 
multiple 
eBooks on 
one device 

4. Can access 
immediately 
from 
internet or 
eBook store 

1. Can be more 
difficult to 
read than 
ink-on-paper 
books 

2. Limited 
screen “real 
estate” 
(area) 

3. A small or 
thin 
paperback 
book could 
be lighter 
than a tablet 

4. Tablet/
eReader 
could be 
expensive, 
risk of loss 
or damage 

5. Battery, 
recharging, 
electrical 
power 
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Reflowable eBook on an Amazon 
Kindle B&W eReader (photo by 
Frank Holleman on Unsplash.com). 

eBook Formats eBook Formats 

ePub Reflowable (RFL). 

ePub is an open-source 

eBook format whose 

standards are controlled by 

the International Digital 

Publishing Forum (IDPF, 

idpf.org), a division of the 

World Wide Web Consortium 

(W3C, w3c.org). ePub can be 

read on MacOS, Windows, 

iOS, and Android with a 

suitable app. The .epub file 

format is a ZIP-compressed 

archive that includes pages in 

XHTML, styles in CSS, 

JavaScript (if any), and media files for images and videos. 

A good theme for reflow able ePub is “text is king.” ePub-RFL 

is a good format for text-heavy documents that have minimal, 

if any, illustrations, although color and black-and-white photos 

and drawings can be added. The font and text size can be chosen 

by the reader for maximum legibility. 

The best way to understand the utility of ePub-RFL is if you 

see someone with an eReader on the train, bus, or airplane, or 

waiting in a doctor’s office. Perhaps this person wants to pass the 

time by reading a novel or enrich themselves with a psychology 

or business book. These eBooks probably contain mostly text 
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Cookbook content suitable for 
ePub-FXL. (Photo courtesy of 
Instant Pot Eats on Google Images.) 

and very few illustrations. The readers can use a lightweight 

eReader that’s easy to carry around and not very expensive. 

ePub-RFL uses XHTML and CSS languages, which allow the 

content to adapt to different-sized eReaders, tablets, and 

orientations (e.g., vertical or portrait, horizontal or landscape). 

ePub Fixed-Layout 

(FXL). Fixed-layout ePub is 

a version of ePub with fixed 

page sizes and elements. An 

appropriate theme for ePub-

FXL may be “media is king.” 

Unlike ePub-RFL, the text in 

ePub-FXL does not reflow 

based on the tablet, screen 

size, orientation, and user 

preferences for type. This 

format is useful when the 

author wants to set a fixed 

relationship between text and photos or media. Examples 

include recipe books and children’s books. 

ePub-FXL allows the use of a wider range of media, including 

grouped photos and captions, animations, videos, and audio 

files. A common use of this format is for children’s books in 

which the text is linked to an audio file so the reader can hear the 

text read out loud. 

Mobi. An abbreviation for Mobipocket, Mobi is a proprietary 

format of ePub developed by Amazon for display on its Kindle 
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eReaders. Mobi is most appropriate for B&W documents that 

are mostly text, although the popular Kindle and Kindle Paper 

White devices do support shades of gray. 

iBooks. These are Apple’s proprietary format of ePub developed 

for the iPad devices. iBooks can be created only on MacOS 

computers using the free iBooks Author page layout program. 

An advantage of iBooks is the extent and variety of media that 

they support, including not only photos, videos, and animations 

but also image galleries, animated panoramic views, 360° 

objects, and embedded web sites. 

Table 2-1. eBook Formats 

Format Create 
with Read on Comments 

ePub RFL 
(reflowable) 

Adobe 
InDesign, 
Apple 
Pages, 
PressBooks 

iPad, 
Android 
tablet; Mac, 
Windows 
computer 

Reflowable format 
provides flexibility for 
text-heavy documents 

ePub FXL 
(fixed-layout) 

Adobe 
InDesign, 
Apple 
Pages 

iPad, 
Android, 
MacOS, 
Windows 

Fixed layout good for 
grouped photos and 
text, e.g., kids’ books, 
recipe books 

Mobi 

ePub with 
file 
converter, 
PressBooks 

Amazon 
Kindle 

Proprietary form of 
ePub, good for 
text-heavy documents 
in B&W 

iBooks 
Apple 
iBooks 
Author 

iPad, Mac 
computer 

Proprietary form of 
ePub with media-rich 
envt. 
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Chapter 2 • Page Layout 
Programs for eBooks 

RICHARD ADAMS 

Adobe InDesign Adobe InDesign 

Part of Adobe’s Creative Suite of graphics software, InDesign 

is a page-layout application that can be used for formatting 

ePubs. The program can export to .epub file format directly from 

the File > Export menu. For laying out ePubs in InDesign, the 

authors recommend following the “Six Caveats of ePub,” as 

shown in the sidebar below. 
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The “Six Caveats” of Reflowable ePub 

1. Keep it Simple 

2. Photos—One photo and caption (if 
any) per page 

3. Inline—All content (text and 
photos) must be inline, meaning 
pasted into a single text box with 
the Text (“i-beam”) tool. 

4. Styles—Style all text with 
Paragraph Styles 

5. Table of Contents—Create an 
Automatic Table of Contents Style 
with headings included to make a 
table of contents 

6. Cover—Create and save in JPEG 
format 

Six Caveats of ePub Six Caveats of ePub 

1. Keep it Simple. Remember that ePub works best for 

text-heavy documents. The idea is to allow readers to 

select the font and size that they find easiest to read, 

then the XHTML page description language allows 

the contents to reflow according to the user’s font 

settings, tablet orientation, and screen size. In this 

format, any photos or media that you want to add 

should be considered embellishments that contribute 

to the theme or to the reader’s understanding of the 

content. Groups of related images, diagrams, and 

captions are best for fixed-layout ePub. 

2. Photos. The authors recommend planning for one 
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photo and caption (if necessary) per page. 

3. Inline. When designing an ePub in InDesign, create a 

single text box and paste all content (i.e., text and 

photos) into this one text box using the Text, or i-

beam, tool. Multiple objects (i.e., text and picture 

boxes) may wind up at the end of the document or in 

different places when the document is exported to 

.epub. 

4. Styles. All text in ePubs should be styled using 

Paragraph Styles. We recommend creating four styles 

and naming them the same as the XHTML tags that 

will be created—p for paragraph, h1 to h6 for 

headings, img for images, and caption for captions. 

The Keep Options in InDesign can be used to avoid 

having a photo and its caption on separate pages as 

much as possible. 

5. Table of Contents. For your book to have a table of 

contents that appears in the eReader or app’s Table of 

Contents tab, create a Table of Contents Style and 

include the heading (i.e., h1 to h6) styles in it. 

6. Cover. For best results create the cover in InDesign, 

Illustrator, Photoshop, or other graphics application 

and save in JPEG format. Then combine the cover 

with the ePub at export. 

Apple Pages Apple Pages 

Apple’s free Pages app can be used to lay out ePubs. Pages 
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exports to .epub directly from the File > Export menu. The 

authors recommend following the same “six caveats” described 

above when designing an ePub in Pages. 

Apple iBooks Author Apple iBooks Author 

Apple’s free iBooks Author app for MacOS, which looks and 

works similar to Pages, is used to lay out Apple’s proprietary 

iBooks version of eBooks. iBooks have a semi-fixed layout 

character because readers are assumed to be using an iPad, or 

an iPad-sized window on the Mac version of the iBooks app. 

iBooks Author is only available for Macs and does not currently 

work on iPads or Windows. (However iPad users could write 

ePub eBooks in Apple Pages for iOS.) iBooks author files have 

the file format .iba and export to the .ibooks format for reading 

with Apple’s Books app. 

iBooks Author supports a wide variety of media. Simply drag-

and-drop photos and videos into the pages and adjust the size. 

More sophisticated media, such as panoramic views and 

rotatable 360° objects can be created with the free program, iAd 

Producer, or with Apple’s presentation program, Keynote. 

WordPress Pressbooks WordPress Pressbooks 

Pressbooks is a plugin for the WordPress web-based content 

management system. Pressbooks is easy for beginners to use 

because pages can be laid out in a WYSIWIG “Visual” tab. 

Authors who know HTML and CSS can edit in the “Text” tab. 

Pressbooks is an enterprise system that supports contributions 
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from multiple authors. Media, including photos and video, can 

be uploaded to Pressbooks and placed in appropriate pages. 

After content is created, Pressbooks chapters can be exported to 

.pdf, .epub, and .mobi formats, as well as .xml for authoring. 

Likewise files can be imported from .docx, .epub, .html, and 

.xml files. 
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Chapter 3 • Editing ePubs 

RICHARD ADAMS 

Editing ePubs enables authors and publishers familiar with 

HTML and CSS to make changes and create special effects 

outside of the originating program. 

Opening an ePub Opening an ePub 

The .epub file type is a compressed archive containing the pages 

in XHTML, style specifications in CSS, and accompanying 

images, fonts, audio, video, JavaScript, and other files (if any). 

Opening and editing an .epub file generally requires a third-party 

app that can read XHTML, such as Sigil (Figure 3.1) or Oxygen 

XML Editor. Opening the ePub gives access to the XHTML and 

styles. 

XHTML is similar to HTML. The X for “extensible” means 

that users can write their own tags, provided that they explain 
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them. M stands for markup, meaning the text and objects are 

indicated or pointed to with tags, which are enclosed in less-

than and greater-than signs. An example of a tag is <p> for 

paragraph. A paragraph needs an opening <p> at the beginning 

and a closing </p> tag at the end. Some tags are self-closing, 

including <img/> for image, <br/> for break (carriage return), 

and <hr/> for horizontal rule (line). With these tags the closing 

“/” is included at the end of the tag. 

HTML and CSS for ePub HTML and CSS for ePub 

Some of the most common tags used in ePubs are the paragraph, 

heading, and image tags (Table 3.1). 
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Table 3.1. HTML Tags for ePub 

<p> paragraph 

<h1>…<h6> heading 1 (largest) to 
heading 6 (smallest) 

<span> span, region of text to 
be selected and styled 

<img/> 
image, e.g., <img 
src=”imagename.jpg” 
/> 

<figure> 
Unites an <img> tag 
and its caption 
(<figcaption>) 

<figcaption> caption for an <img> 
tag 

<br/> 

break, or carriage 
return (self-closing), 
can be replaced with 
styles “padding” or 
“margin” 

<hr/> 

horizontal rule, or 
line; there are no 
vertical rules, but 
they can be made 
with a border-left or 
border-right style on 
an object. 

To style a given tag with CSS, the tag must first be selected. This 

can be done by siting the tag itself, such as “p” for paragraph. 

However the specified style will be applied to all paragraphs. 

To select one specific paragraph, it’s helpful to identify that 

paragraph with an ID (e.g., <p id=”first-para”>). The ID should 

be an alphanumeric name with no spaces. An ID can only be 

applied to one tag on a page. To select multiple tags, use a class. 
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The format is similar: <img class=”body-fig”>. To cite an ID in 

CSS, use the # symbol. A period (.) indicates a class. 

Table 3.2. HTML Identifiers for CSS 
Styling 

Identifier Example in 
HTML 

Selector 
in CSS 

tag, e.g., 
<p> <p> p 

ID <p 
id=”first-para”> #first-para 

class <img 
class=”body-fig”> .body-fig 

Table 3.3 shows some styles that can be applied to text. 

Table 3.3. Styles for Text and 
Images 

text image 

font-family: 
font-size: 
font-style: 
font-weight: 
line-height: 
color: 

width: 
height: 
float: 
margin: 

Creative Effects with ePubs Creative Effects with ePubs 

Some special effects that enhance ePubs include drop-caps, drop 

shadows on text and images, and borders on images. 

Decorative fonts. Royalty-free fonts available from Google 

Fonts and other sources can be used in web-based and ePub 
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eBooks. Fonts can either be linked to their internet sources as 

style sheets or included on the web server or in the eBook. 

Technically an ePub should be readable without being connected 

to the internet, therefore it’s best to download the font and 

include it in the ePub. When editing an ePub in Sigil, include 

the font file in the Fonts folder and specify it in the style sheet 

(Figure 3.2). 

Figure 3-2. Decorative font placed in the Fonts folder and specified for 
the h1 tag in an ePub. 

Drop-caps. Drop-caps can be created by making the first letter 

of the first paragraph larger than the surrounding text. In the 

example (Figure 3.3), the first letter in the paragraph, “C,” is 

selected using the ::first-letter selector, which is built in to the 

latest version of HTML. The letter “C” has the surrounding text 

wrapped around it using the “float” left style. the letter “C” 

is set to 4.4 times the size of the other text using the “em” 

measurement. (One em is the size of the text in points, so for 

14-pt. text like that shown, one em would be a square 14 pt. 
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on each side.) The “C” is set to wrap the surrounding letters 

using the “float: left” style. Margins are set for the top, right, 

bottom, and left positions to move the text further away to the 

right of the “C” and bring it closer to the bottom. The letter has a 

drop-shadow created with the text-shadow style, which has four 

specifications—right offset, vertical offset, blend distance, and 

colour. 

Figure 3.3. Selectors and styles for creating borders and drop shadows 
around images and drop caps for text. 

Images. Images, like the one shown in Figure 3.3, can have 

borders applied using the “border” style, with specifications for 

width, line type, and colour. A drop-shadow can also be applied 

using the “box-shadow” style, which is similar to text-shadow 

described above. (Not all platforms, eReader apps, and eReaders 

may support the drop-shadow style.) 
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Small caps. These are smaller uppercase letters at the beginning 

of a chapter or section (Figure 3.4), often following a drop-cap. 

Small caps can be created by selecting the desired region of text 

with opening and closing <span> tags, then setting the “font-

variant: small-caps” style. 

Figure 3.4. Example of small caps set with the “font-variant” style. 

Sidebars. Sidebars are boxes with ancillary information relating 

to the current chapter or section (Figure 3.5). Sidebars can be 

created by inserting one styled <p> tag, or if more than one 

paragraph, a <div> or division tag. The sidebar can then be 

styled with the “border” and “background” styles. 

Figure 3.5. Example of a sidebar with coloured background and border 
with rounded corners (border-radius). 

Pull quotes. These are one or more sentences or phrases taken 

from the text that are set in much larger type in order to add 
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interest to the text (Figure 3.6). A pull quote can be created by 

especially styling a <p> paragraph tag, or using a <div> division. 

The text can be set to a larger font and with quote marks if 

appropriate. 

Figure 3.065. Example of a pull-quote. 
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Chapter 4 • Media in eBooks 

RICHARD ADAMS 

“Media” refers to audio, video, and animation files included 

in eBooks. The appropriateness and ability to include media 

depends on the eBook file format and anticipated viewing device 

and audience. Depending upon the intended audience and 

purpose of the eBook, media may be appropriate in the ePub 

format and is a strong point of iBooks. It may not be appropriate 

for Mobi because most B&W eReaders do not have speakers or 

enough storage space for large video files. 

Of the various media types shown in Table 4.1: 

• audio refers to sound, examples of which could 

include background music, a voice reading the text in 

a children’s book, or a clip of a musical instrument. 

• video refers to moving bitmapped pictures taken with 

a cell phone, digital camera, or video camcorder. 
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Videos, like pictures, represent images with 

microscopic pixels, or squares of light/dark and 

colour, which produce large files. 

• animation generally refers to moving images drawn 

with vector graphics; that is, objects are defined by 

mathematical equations for points, lines, and arcs. 

Vector graphic animation files tend to be small 

because the mathematical modeling is text-based. 

Animation may play by itself or may include user 

interaction, such as buttons to start-stop-pause-rewind 

the scene. Vector-based animations can be exported to 

bitmapped formats, including animated GIF and 

QuickTime. 

Table 4.1. Media in eBooks 

eBook 
Format Audio Video Animation 

ePub 
from 
InDesign 

√ √ √ 

ePub 
from 
Pages 

√ √ — 

iBook 
from 
iBooks 
Author 

√ √ √ 

Mobi 
converted 
from 
ePub 

 — — √ 
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Audio and Video Audio and Video 

Figure 4-1. Adobe InDesign’s Media 
palette 

Any YouTube fan can attest to the explosion of digital video 

on the web and how it has revolutionized communication—be 

it for education, product information, or just sharing personal 

experiences. Audio and video files can be added to pages using 

Adobe InDesign and Apple Pages, then exported to ePub. 

InDesign’s Window > Buttons and Forms palette can be used to 

add buttons that control an audio or video file’s playback. Audio 

to be inserted into InDesign must be in MP3 or MP4 format. An 

online converter may be helpful in getting the correct file type. 

Most digital cameras today can record standard-definition (SD) 

and high-definition (HD) videos (Table 4-2). Camera types 
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range from cell phones to point-and-shoot, advanced amateur, 

and single-lens reflex (DSLR) cameras, along with amateur 

pocket video cams and shoulder-mounted professional models. 

Higher-level cameras offer more professional features, such as 

more control over camera settings and stereo recording from an 

external microphone. 

Table 4-2. Video Resolutions 

Format 
Resolution 
(pixels) 

Suggested 
Use 

Standard 
Definition 
(SD) 

640 x 480 

iPad, 
locations 
where space 
is limited 

High 
Definition 
(HD 720) 

1280 x 720 

small-screen 
TVs and 
standard 
video 
window on 
laptops 

High 
Definition 
(HD 
1080) 

1920 x 
1080 

large-screen 
TVs and 
full-screen 
on large 
monitors 

Since digital video consists of a series of bitmapped images, file 

size limits their length and quality. A video is like a series of 

Photoshop images at 24–30 per second. If the length and width 

of the frame are doubled, then the file size quadruples. File size 

is a major consideration in the length and quality level of the 

video. 

File format is another important consideration (Table 4-3). 
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Choose a format depending upon whether your movie will be 

played on a Windows, Apple, or tablet computer. 

Table 4-3. Video Formats 

Format 
File 
extension Use 

Apple 
QuickTime .mov 

MacOS 
and iOS 
devices 

MP4 .m4v, 
mp4 

MacOS, 
iOS, and 
Windows 

Windows 
Movie 
Player 

.wmv 

Windows 
computers 
Apple 
computers 
with 
plugin 

Video Programs Video Programs 

A video editing program enables you to edit your video by doing 

such things as: 

• deleting scenes that you don’t want 

• splicing scenes you do want into a continuous 

sequence 

• adding transitions between scenes 

• adding titles 

• creating special effects, such as time-lapse 

• deleting sound and adding a voiceover (narration) 
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Apple iMovie Apple iMovie 

iMovie is an easy-to-use program for basic video editing, 

provides an appropriate example of a video editing program for 

a one-semester course in web design. 

Opening a Movie 

1. Transfer your unedited movie from your camera to 

your computer. 

2. Open iMovie and select one of the readymade themes 

(or No Theme). 

3. Select Import Media and open your unedited movie, 

which will come into the Clips window. 

4. In iMovie, select the entire clip and move to the 

editing window. 

Deleting Unwanted Footage 

1. In the editing window, place the play head where you 

want to cut the clip. Placing a marker (M) is a 

convenient way to evaluate a starting and stopping 

point. Then select Split Clip (B). 

2. After splitting the clip you can select and delete the 

sections you don’t want. 

Adding Transitions 

1. From the Content Library, select Transitions. 
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2. Find the transition you want and drag it in between 

two clips, or at the end of a clip. In the example, a 

Fade to Black transition was added to the beginning 

and end of the movie. The length of the transition can 

be set in seconds and tenths. 

Adding Titles 

1. From the Content Library, select Titles. 

2. Find the title you want and drag to the location where 

you want it to appear—at the beginning or end of the 

clip, or in the middle. None of these locations add 

time to the movie. The title can be placed before the 

start or after the end of the clip, which lengthens the 

movie. 

Lowering or Deleting Sound and Adding Voiceover 

1. To lower the volume in a clip, select the clip and, 

using the Volume Adjust control above the play 

window, reduce the volume 100% to the level you 

want. The volume can also be faded in and out by 

dragging the dot above the volume level line in the 

sound window. 

2. To delete sound, select the clip and then choose 

Modify > Detach Audio. The audio will appear below 

the clip as a green line. Select this line and delete. 

3. To add a voiceover, select the clip and move the 

playhead to the location where you want to start the 
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narration. 

4. Choose Window > Record Voiceover. The 

microphone icon will appear below the play window. 

5. Click the start button, speak into the microphone, and 

click stop when finished. The narration will be added 

to the clip. 

Exporting 

1. To export your edited video, click the Share button 

(or File > Share), then select File. 

2.  The dialog box offers a choice of resolutions for 

output, along with an estimate of the file size. Note 

that file sizes are proportionally larger with HD-720 

and HD-1080 than with SD. 

Animation Animation 

Possibilities for using vector graphic animations in ePubs are 

summarized in Table 4.1. Vector graphic animations can be 

created for ePubs using InDesign, with its Buttons and Forms 

and Animation palettes. InDesign does not support HTML5 

animations made with Tumult Hype, which is compatible with 

iBooks. 

Animations can also be created using CSS via the @keyframes 

rule and associated objects. However CSS animations cannot be 

linked to control buttons. The animated object itself can serve 

28  •   RICHARD ADAMS



as a “button” using the “:hover” and “:active” pseudoselectors 

along with the “animation-play-state” style. 

Animations can also be created with the jQuery JavaScript 

library’s “animate” and “draggable” functions, and these can 

be tied to buttons for user control. The jQuery libraries can be 

imported into ePubs using an editing program like Sigil. 

Animations from Tumult Hype can be exported as Apple 

“Widgets” (file type .wdgt), then dragged-and-dropped into 

iBooks Author to appear in iBooks. 

Table 4.1. Animation in eBooks 

Animation 
type 

User 
Interaction 

eBook 
Formats 

CSS 
@keyframes 
rule and 
connected ID/
class 

Hover or 
click states 
on objects 
(no 
buttons) 

ePub RFL and 
FXL 
ePub from 
PressBooks 

JavaScript 
jQuery library 
“animate” and 
“dragable” 
functions 

Buttons, 
click/hover 
states 

ePub RFL and 
FXL, iBook 
“widgets” 
with iAd 
Producer 

Adobe 
InDesign 
(Buttons and 
Forms, 
Animation) 

Buttons, 
click/hover 
states 

ePub RFL and 
FXL 

Tumult Hype 
Buttons, 
click/hover 
states 

iBooks 
“widgets” 
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Animation in CSS 

Animation with CSS can be done with a named @keyframes 

rule connected to an HTML tag with the “animation-name” 

style. The @keyframes rule specifies, using “start” and “stop” 

points or percentage values, the change points of the tag in 

the course of the animation. In Figure 4-2 a car image has 

been animated using an @keyframes rule named “letsgo” that 

is connected to the car image using the style, “animation-name: 

letsgo;.” Additional styles specify the “animation-duration” in 

seconds (“s”), “animation-fill-mode” (position upon completion, 

i.e., at the end or at the beginning), and “animation-timing-

function” (“ease” means to start and end slowly). 

The @keyframes rule specifies two keyframes, one at the start 

(“0%”) and one at the end (“100%”). Within the keyframes, the 

“left” position style is specified in pixels from the left of the 

browser window. For the “left” style to work, the tag must be set 

to “position: relative.” 

The CSS animation function is documented on W3Schools site 

[New Window]. 
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Figure 4-2. An example of animation created only with CSS using the 
@keyframes rule connected to the “car” image. (Car image courtesy of 
pngtree.com.) 

Animation created purely with CSS has limited user interaction/

control, which could be introduced by linking the “animation-

play-state” to a “:hover” or “:active” pseudoclass. To do so, 

the designer would write “#car:hover {animation-play-state: 

running;}. The animation would then start when the reader 

positions the mouse over (or taps) the car. Using the “:active” 

pseudoclass would make the car move when clicked. 

Another way to introduce user interaction into a CSS animation 

is to add a simple JavaScript button. The button would be written 

as shown in Figure 4-3. For this setup, the animation-play-state 

is set to “paused” and then changed to “running” with the button 

and code. 
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Figure 4-3. Code for a simple JavaScript button with statement to start 
the animation. 

Animation with jQuery 

jQuery is a curated library of JavaScript functions managed 

by the jQuery Foundation, which was started by a group of 

professors at the MIT Media Lab who wrote and contributed 

JavaScript functions to the library and offered it as an open-

source resource to web and eBook developers. The jQuery code 

consists of a small JavaScript file that can be downloaded and 

hosted on the developer’s own web site, or linked-to as an 

external resource. 

In this example (Figure 4-4), the “car” image was animated by 

connecting the “Start” button to the <img> tag using the jQuery 

“animate” function. The button was assigned an ID of “button,” 

while that of the car image is “car.” The animation moves the car 

image an additional (“+=”) 850px to the right and takes 3,000 

milliseconds (3 sec.) to complete. 

Figure 4-4. Animation created with the jQuery JavaScript library. 
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Animation with InDesign 

eBook creators using Adobe InDesign can create animations 

using InDesign’s Animation palette (Window > Interactive > 

Animation, Figure 4-5). After an object is placed and selected, 

the Animation palette can be used to assign one of numerous 

animation presets, along with the triggering event, duration, 

number of repetitions, and ease functions. The animation’s 

appearance can be previewed in the ePub Interactivity Preview 

palette (shown in Figure 4-4). Assigning a motion preset to an 

object gives it a motion guide (green line in the figure) that can 

be changed in length and curvature. 

Figure 4-5. Animation in Adobe InDesign, created with the Animation 
palette and previewed with the EPUB Interactivity Preview palette. 
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Animation with an Animation Program 

Several animation programs can be used to create animations in 

eBooks. These offer the possibility of creating more complex 

animations than some users may feel up to using CSS, 

JavaScript, and jQuery. An inexpensive and easy-to-use 

HTML5-based animation program is Tumult Hype (Figure 4-6). 

Hype animations can be exported directly as “widgets” for drag-

and-drop placement in Apple iBooks. However the company 

advises that it’s still working on implementation for ePubs. 

Figure 4-6. Animation with Tumult Hype, showing the timeline, layers, 
and motion guide. 

34  •   RICHARD ADAMS

http://pressbooks.library.ryerson.ca/ebooks/wp-content/uploads/sites/38/2018/05/4-5_HY-W_HypeAnimation.png
http://pressbooks.library.ryerson.ca/ebooks/wp-content/uploads/sites/38/2018/05/4-5_HY-W_HypeAnimation.png


Chapter 5 • Apple iBooks 

RICHARD ADAMS 

iBooks and iBooks Author iBooks and iBooks Author 

Apple iBooks (.ibooks) are a  type of eBook developed with the 

iPad in mind, however they can also be read on an iPhone or 

Mac computer with the iBooks app. 

iBooks are written with Apple’s free MacOS program, iBooks 

Author, available in the App Store. The program has an interface 

similar to Pages. An iBook cannot be written on a Windows 

computer or with an iOS device. 

Since iBooks are assumed to be read on an iPad (or an iPad-sized 

window on a Mac), they offer more certainty over page layout 

than with ePubs. Media can be easily inserted into iBooks by 

dragging and dropping. Some specialized media (panoramas and 

360° views) must be created with the free iAd Producer app. 
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iAd Producer iAd Producer 

iAd Producer is a free utility available from Apple’s developer 

site (developer.apple.com) that can be used for producing 

complex interactive elements (“widgets”) for iBooks. Widgets 

are automatically written in HTML, CSS, and JavaScript. iAd 

Producer project files (type .iadproj) can be exported as widgets 

(.wdgt), then drag-and-dropped to be placed in iBooks Author 

pages. 

iAd Producer’s interface includes an “Assets” panel for 

importing media (photos and video) and an “Objects” panel 

with numerous interactive objects into which the media can be 

placed. 

Two of the most complex and interesting widgets are interactive 

panoramas and 360° objects, which are similar in structure. An 

interactive panorama requires at least 6 consecutive images of 

a scene that’s centred on the photographer. Ideally two sets 

of photos are supplied, one at the iPad’s native resolution 

(1024×768 pixels) and another at double this resolution 

(2048×1536 pixels) for Retina™ displays. Using iAd Producer 

and a panorama widget, the user places the photos in consecutive 

panels. When the panorama is exported to a widget and viewed 

on an iPad, the panorama can access the gyroscope to detect 

motion, and the scene will rotate in sync with the that the iPad 

is pointed toward. Thus the panorama widget would be useful as 

part of a tour book or building guide. 

The panorama can include buttons or “hot spots” for objects in 

the scene, such as a statue. When the user clicks the button, the 
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widget will advance from the panorama page to a second page 

with a photo and information about the object. 

The 360° widget shows an object that users can rotate by 

touching the iPad screen. This widget likewise requires two sets 

of preferably 8 or more photos of an object. Ideally the object 

should be placed on a turntable and rotated 360° for the 8 photos, 

or 45° between photos. 

Users can include JavaScript, including the jQuery library, into 

iAd Producer widgets. jQuery would be useful for creating 

animations, including the “draggable” function that allows 

readers to click-and-drag an object around the stage. 
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Part 2 • Class Tutorials 
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Tutorial 1 • ePub from InDesign 

RICHARD ADAMS 

In this tutorial we will be creating a reflowable ePub from 

InDesign and viewing it in Apple Books. When creating your 

ePub keep in mind the “Six Caveats of ePub”: 

Six Caveats of ePub 

1.     Keep it simple 

2.     Maximum of one picture and one caption per page 

3.     Everything must be inline 

4.     Style all text 

5.     Create cover as JPEG 

6.     Use a Table of Contents Style 
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What You will Need What You will Need 

1. text in .doc or .txt format, 500+ words 

2. photo for full width of page, 144 ppi 

3. photo for 1/4 page, 144 poi 

Create Document Create Document 

1. Open a new InDesign document > 384×768 px 

portrait with Primary Text Frame. The page size does 

not really matter because ePubs have no pages, the 

“pages” are created by the eReader app. However 

384×768px looks on a Mac monitor closely 

resembles the eBook’s appearance on an iPad. 

2. Place the tutorial text into the document. 

3. Define a picture box for the photos, then place photos 

on the Pasteboard, size as desired, and place inline 

with the text (cut and paste with the Text tool). 

Defining the picture box first avoids getting an 

unmanageably large image on the pasteboard. Object 

> Fitting > Fit Content Proportionally will fit the 

image into the picture box you defined. Then Object 

> Fitting > Fit Frame to Content will size the picture 

box to the proportionally-fit picture. 

4. On export to ePub, InDesign will shrink images to 

less than full width. For full-width images, select 

Object > Object Export Options and set for ePub > 

Custom Width: 100%. 
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Setting Object > Object Export Options > EPUB and HTML > Custom 
Width: 100% will keep images intended to be full-width at the intended 
size. 

Set Up Paragraph Styles Set Up Paragraph Styles 

Set up Paragraph Styles according to the table and apply to the 

respective text and photos. 
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Paragraph Styles for ePub 

Style Used for Settings 

p paragraph 
(body) 

• Palatino Regular 14/Auto 

• 12pt space before 

• Keep first 2 and last 2 lines together 

• Export tagging: <p> 

h1 heading 1 

• Palatino Bold 18/Auto 

• 12pt space before 

• Choose colour 

• Export tagging: <h1> 

img images 

• Palatino Regular, 12/Auto 

• 12pt space before, align center 

• Export tagging: <p> 

caption captions 

• Palatino Italic, 10/Auto 

• Indent 24px left and right 

• Keep with previous 

• Export tagging: <p> 

Create Table of Contents Create Table of Contents 

4. Create a Layout > Table of Contents Style > and 

select h1 as the style to include. 
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5. Name the TOC Style something you will remember. 

Export to ePub (Reflowable) Export to ePub (Reflowable) 

6. File > Export > ePub (Reflowable) 

7. Choose EPUB3 format. 

8. Select the cover image provided or make your own in 

JPEG format. 

9. Select the TOC Style that you created. 

10. Check Split Document and set to <h1> so each 

heading will start on a new page. 

Split Document set to h1 starts headings on a new page. 
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Open in Books Open in Books 

10. Open the ePub in iBooks and see how the page 

layout, text, and photos compares with the InDesign 

document. 

Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=167 
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Tutorial 2 • Design for eBooks 

RICHARD ADAMS; AKOS KATONA; BETTINA TABEL; AND 

OKKE SCHLÜTER 

User Experience Design (UXD) and “DesignAgility” User Experience Design (UXD) and “DesignAgility” 

Thanks to Prof. Dr. Okke Schlüter, HdM-Stuttgart, for 

contributing to this section. 

When designing eBooks, designers have to think about the 

purpose of the eBook, the audience, and the readers’ experience 

as they use it — a process commonly called “user experience 

design” (UXD). “DesignAgility,” a systematic approach to UXD 

for media, was created by Okke Schlüter from HdM-Stuttgart 

and Stefanie Quade (Quade, Stefanie, and Okke Schlüter, 

DesignAgility—Toolbox Media Prototyping. Amazon Kindle 

Direct Publishing, 2019). DesignAgility combines “design 

thinking” with “agile manufacturing.” 
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The first step in DesignAgility is to think of a challenge or 

problem that people want to solve. For an eBook, this could 

include questions like: What is the eBook’s purpose—to inform, 

persuade, entertain? What is the dominant media—text, photos, 

videos, animation? Who will the audience be, and what are their 

characteristics, interests, and possible challenges they may face 

in reading it? 

The DesignAgility approach includes defining “personas,” who 

are a representative sampling of presumed readers, and their 

characteristics. The personas’ perception and use of an eBook 

can be expressed in “user stories.” 

 

DesignAgility Step What to Do 

Discovery 
Define the purpose of your eBook: 
• inform, persuade, entertain? 
• dominant media—text, photos, videos, animations? 

Interpretation Define several “personas,” or presumed users, their ages, occupations, 
interests, and any sensory challenges they face. 

Ideation Write “user stories” about why each persona will be interested the eBook and 
how they will interact with it. 

Specification 

Sketch out some sample page layouts for your eBook: 
• cover 
• first page of chapter 
• subsequent chapter pages 

Implementation Design the eBook 

Evaluation Design Critique 
• show your design to another class member and ask for their feedback. 

Deployment Publish the eBook and assess its impact 
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DesignAgility Example 

Discovery. Define a challenge or problem that people want to 

solve. An author and designer want to write an informational 

eBook about cat breeds. The eBook will feature color photos 

of each breed, along with information about the breed, such as 

history, origin, characteristics, temperament, medical conditions, 

nutritional requirements, food preferences, and grooming needs. 

The photos and text are equally important. The designer wants 

the eBook to appeal to readers “from 6 to 106.” 

Interpretation and Personas. “Granny Smith” is an 86-year-

old grandmother who loves cats and reads everything she can 

find about them. She visits doctor’s offices and complains about 

the wait times. Her grandchildren bought her a low-cost B&W 

eReader with WiFi so she could read eBooks while waiting. 

Granny has some visual challenges, including presbyopia (needs 

reading glasses to see up close) and the beginnings of cataracts 

(cloudy vision). 

“Junior Jones” is a 6-year-old boy who likewise developed a 

strong interest in cats. He has an iMac 21″ computer and an iPad 

Mini that he uses to read eBooks at home and when traveling. 

Junior loves to see pictures of cats and could benefit from audio 

on the web site that could read the text to him. 

Ideation and User Stories. In the “Cats” eBook, the pictures 

and text are equally important. The photos should look good in 

color and when rendered in black-and-white. The text should 

be high-contrast and enlargeable and be readable with a screen 
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reader or included audio. The pages should look good on both 

desktop computers and tablets. 

Granny Smith likes to look at pictures of cats so the photos 

should look good in both color and B&W. The photos should be 

set up as links so that when Granny clicks or taps on an image, 

the link brings up a larger image. Being able to enlarge the type 

will make it easier for Granny to read. 

Junior likewise enjoys seeing enlarge photos of the cats. As he 

learns to read, it’s helpful for him to tap a button that reads the 

text to him. 

Writing Your eBook Proposal 

1. Think about a challenge that you could 

address with an eBook. What will be 

more important—text or photos? 

Describe how you will construct the 

eBook. 

2. Define some personas of prospective 

readers and their characteristics. 

3. Write a user story for each persona, 

describing what will interest them about 

your eBook and how they will interact 

with it. 
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4. Draw a basic layout of your cover and 

one of the chapter title pages, including 

text, full-width photos, and part-width 

photos with text wrap. 

Cover Design Cover Design 

Thanks to Akos Katona, FCAD Catalyst Research Hub, for 

contributing to this section. 

The cover is so important for conveying the title, author, and 

other information about an eBook. Keep in mind that the title 

should be visible when viewed as a thumbnail in an eBook 

catalog. 

This example shows how, as compared to simple text, an eye-

catching cover design can enhance the eBook’s appearance and 

also convey its message and improve sales. 
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These before-and-after book covers were created by designer Akos 
Katona for his guest lecture in Ryerson’s summer 2019 eBooks class. 
Note how the photo and type design increase in impact and legibility of 
the “after” cover. For his design, Akos chose a royalty-free image with 
enough white space to set the title type with good contrast. 

Research Research 

A key consideration for a cover is the tone of the eBook. For 

example the sample eBook cover for What the Bark above takes 

a humorous tone in looking at the psychology of dogs. A 

popular-market eBook about canine nutrition in health or a 

veterinary textbook about diseases and illnesses of dogs would 

take respectively more serious tones. 

Designer Akos Katona recommends researching the topic of 

the eBook and compiling various photos and type faces into a 

“mood board,” a collage of related photos, fonts, and logos. The 

mood board can be a valuable tool in exploring the tone that 

the publisher wants the eBook to take. To compile resources 

he gets photos from Unsplash [New Window] or Pixabay [New 
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Window], fonts from Adobe Typekit and Google Fonts, and 

icons and vector artwork from The Noun Project and Vecteezy 

[New Window]. 

eBook cover requirements vary by publisher and platform and 

are constantly evolving as new devices become available. 

Monica Dube discussed various cover requirements in her 

January 2019 article, “Complete Guide to Book Cover 

Sizes—Why Do They Matter? [New Window]” 

Cover Resolution Requirements 

Format Resolution 

ePub/Adobe 
InDesign* 1024×768px 

Apple iBooks 2500px longest side 

Amazon Kindle 1600px shortest side 

Pressbooks 2500×3750px 

* 
author-recommended 

Following are some recommended steps to design an eBook 

cover: 

Procedure Procedure 

1. Determine the size of cover you need in pixels, e.g., 

for Pressbooks it’s 2500×3750 pixels. 

2. Take a photo or choose a royalty-free image that 

expresses the theme of the eBook. The resolution 
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should be at that required by the eBook format, and 

the photo should have a lot of white or pale color at 

the top so the title type can be set with good contrast. 

3. If the image could stand to be lighter, apply a 

Gradient Overlay gradient in Photoshop (Layers 

Palette > fx > Gradient Overlay, see below). 

4. Import the image into Illustrator and name the layer 

Background. 

5. Add another layer on top of the Background and call 

it Type. 

6. Choose a royalty-free font (e.g., Google Fonts [New 

Window]) that conveys the theme of the book and is 

also easy to read in thumbnail size. 

7. In Illustrator, pick up (measure) colors from the 

image using the Eyedropper tool, import into Color 

Themes, and add several related colors to your 

Swatches using a scheme of your choice (e.g., 

analogous, complimentary, triad, . . . ). Use the colors 

to set the title, author, institution, and other 

information. (Details below.) 

8. Make a triangle or other shape at the top or at the 

corner with the edition or series. 

9. Export the book cover at the required resolution using 

the File > Export > Save for Web dialog box. 
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Photoshop Photoshop 

The following illustrations show how a stock image was 

prepared for use as a cover photo by applying a gradient in 

Photoshop to lighten the background, creating more contrast for 

the title. The original image was 3239×4315 pixels and was 

exported at 2500×3750 pixels for Pressbooks. 
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Cover image before application of gradient in Photoshop to lighten the upper part and 
make space for the title. (Photo by Fang Wei Lin on Unsplash.com.) 

Cover photo after applying a gradient in Photoshop to lighten the upper part and 
allow for more contrast with the title. 
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Photoshop Layers palette showing the original image (“Background Image”) and 
gradient from white to transparent. 

Photoshop Gradient Editor dialog box showing the transparent-to-white gradient 
applied to the image. 

Fonts Fonts 

Google fonts (google.com/fonts) is a great source of royalty-free 

fronts to use on eBooks covers. 
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Screen capture of Google Fonts showing the 
Roboto Slab font used for the cover. 

Illustrator Illustrator 

The edited cover image was placed in Adobe Illustrator and set 

as the background layer. The color of the orange bookmark was 

measured with the Eyedropper tool and imported into the Color 

Themes palette. The Complementary color scheme was selected 

and the green color was used for the title. 
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Finished cover and Complementary color theme in Illustrator 

Organizing Files Organizing Files 

Compiling multiple versions of photos, fonts, and logos will 

result in a collection of files that may be linked to page layout or 

illustration documents. To keep all these assets together and in 

one place, it’s advisable to create a folder for each cover job. 
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Design Critique Design Critique 

Thanks to Prof. Bettina Tabel, HdM-Stuttgart, for contributing 

the idea of design critiques. 

When designing a cover or eBook interior page, it can be useful 

to get a design critique from an objective third party. Following 

is a list of questions to consider: 

Book Cover 

1. What is the purpose of the eBook? Audience? Is this 

clear from the title and design? 

2. From the title and cover photo (if any), are the subject 

and theme of the book clear? 

3. Does the color scheme fit the target group and the 

subject? Should the color scheme be neutral, pastel, 

bright, complementary, analogous, or other theme? 

4. Is the font selection appropriate to the eBook’s title 

and audience? 

5. Is the font legible (size, contrast)? Could it benefit 

from a drop shadow or complimentary-colored 

background? 

6. If the cover has one or more photos, have the image 

rights been clarified? 

7. Are photos sized appropriately to the cover and 

according to the publisher’s or platform’s 

requirements? 
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Interior Pages 

1. Is the text legible—large enough to read, and with 

space between paragraphs? 

2. Are headings distinct and separated from sections? 

3. Do special effects (drop caps, callouts, sidebars) 

contribute to the theme of the book without being 

distracting? 

4. Are photos large enough for readers to see detail? If 

the reader touches a photo, does it link to a larger 

version? 

5. Are chapter and section separations clearly indicated? 

Example of a poorly designed content page 

Problems with the example above: 
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1. Small heading and text size in default view 

2. Insufficient separation between heading and text 

3. Boring, overused Times Roman font—difficult to 

read 

4. Photo should be set to 100% of page width to be 

easier to see 

5. Insufficient separation between paragraphs 

 

Well designed content page 
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Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=279 
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Tutorial 3 • Web-Based eBook 

RICHARD ADAMS 

A manually-created, web-based eBook may be a good solution 

for short books of, say, 6 pages or less. We will be using this web 

eBook to demonstrate HTML tags and CSS styles that are useful 

for creating special effects when editing the XHTML in eBooks. 

Orientation to the Web Page Orientation to the Web Page 

1. Open Dreamweaver or a free HTML editor, then open 

the HTML file for the web eBook. Note how the page 

has been designed with a fixed layout that looks like 

an 8.5×11″ page. 

2. If you’re new to HTML, note the use of the tags to 

mark all the sections and text, including <p> 

paragraph, <h1> to <h6> headings, <img> image, and 

<div> division for objects and grouping other tags. 
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3. Also note the <style> tag in the <head> of the 

document and how it is used to select specific tags 

and apply specific styles. Tags can be selected by 

their tag type or by labeling them with an ID (used 

once per page) or class (used multiple times in a 

page). 

HTML Tags for ePub 

<p> 

<h1>…<h6> 

<img> 

<figcaption> 

paragraph 

heading 1 (largest) to heading 6 (smallest) 

image, e.g., <img src=”imagename.jpg” /> 

caption 

HTML Identifiers for CSS Styling 

Identifier Example in HTML Selector in CSS 

tag, e.g., <p> <p> p 

ID <p id=”first-para”> #first-para 

class <img class=”body-fig”> .body-fig 
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Styles for Text and Images 

text image 

font-family: 

font-size: 

font-style: 

font-weight: 

line-height: 

color: 

width: 

height: 

float: 

margin: 

Creative Styles Creative Styles 

Let’s apply some creative styles to the web eBook. 

1. Decorative Title Font 1. Decorative Title Font 

Find a decorative Truetype font on google.com/fonts, such as the 

font “Rye” in the screen capture. Add the .ttf file to the web page 

folder and bring it into the page by adding an @font-face rule to 

the <style> statement: 

  @font-face { 

      font-family: Rye; 

      src: url("Rye-Regular.ttf"); 

      } 
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In the style sheet, specify the font for the <h1> tag: 

  h1 { 
      font-family: Rye; 
     } 

2.2.  Drop Cap Drop Cap 

For the drop cap, enclose the first letter in a <span> tag, then 

style the span so the letter is 3 times normal size (3em or 300%), 

float left, and put the required margin around it. You could 

also use a different font. If drop cap has too much space at the 

bottom, e.g., it’s only 2 lines high but occupies 3 lines, you could 

move the third line up using negative margin.d 

  span { 
     font-size: 3em; 
     float: left; 
     margin: 0 6px -3px 0; 
     } 

3.3.  Image with Text Wrap Image with Text Wrap 

Place the image of the whale caricature into the page using 

the <img> tag. Label the <img> tag with a class, like <img 

class=”left-float”>, because you will want to style other images 

differently. Style the .left-float class to the width that you want 

and float: left;, then add margin to create space around the 

image. Other suitable image styles include border and box-

shadow (the box-shadow style will be deleted if used in 

Pressbooks). 

  .left-float { 
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     width: 512px; 
     float: left; 
     margin: 0 12px 6px 0; 
     border: 1px solid dimgray; 
     box-shadow: 3px 2px 6px gray; 
     } 

4.4.  Full-Width Image Full-Width Image 

Place the drawing of the whale into one column. Set width to 

occupy the whole column. You can also add a border and a drop 

shadow (text-shadow) to the image. 

5. Callout or Pull Quote 5. Callout or Pull Quote 

A callout or pull quote is a sentence or phrase from the text 

that’s set in larger type. It breaks up the text and calls attention to 

phrase in question. To create a callout, enclose the text in <span> 

or <div> tags, or in a <p> paragraph with a unique ID or class, 

set to the width of the column, and specify font-family and font-

size. Use margin and padding to make space around and text 

inset. 

In the sample callout and sidebars shown in the Moby Dick 

web-based eBook, the columns are 396px wide so the callout 

and sidebar paragraphs were set to 324px. The paragraph was 

centered in the column with the style “margin: 0 auto;” and font 

size, background, and border were also specified. 
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6. Sidebar 6. Sidebar 

A sidebar presents short information that’s an aside to the main 

story. It also breaks up the text and adds interest. Set up similar 

to a callout or pull quote. 

Example of a 2-page web-based eBook with special 
effects. 
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Page structure of the web-based eBook, showing the div element “page” 
that creates the page and the div element “text” for the text. 

 

XHTML tags and CSS code for the drop-cap, callout, full-width image, 
and image with text wrap. 
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Page 2 of the web eBook with code for the sidebar. 
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Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=244 
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Tutorial 4 • Adding Special 
Effects with HTML/CSS and Sigil 

RICHARD ADAMS 

Sigil (https://sigil-ebook.com) is a free, open-source app for 

editing ePubs that was developed by Google. An ePub is actually 

a compressed file with separate folders for its contents. The 

compressed file can be opened, edited, and saved using Sigil. 

Open ePub in Sigil Open ePub in Sigil 

1. Copy the ePub file that you created in Tutorial 1. 

2. Launch Sigil and open the .epub file. 

3. Note the structure of the ePub file: 

• Separate folders contain the HTML files, CSS, 

images, fonts, and media. 
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• The text is identified with HTML tags, classes, and 

IDs. 

Epub opened in Sigil to show file structure and use of HTML tags and 
CSS styles. 

Style the ePub Style the ePub 

1. Using your knowledge of HTML and CSS to identify 

objects, apply some innovative styles to the ePub, 

e.g.: 

• Create a text wrap by adding a “float” style to the 

image. 

• Create a dropcap on the first paragraph using the 
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p::first-letter selector. 

Save your styled ePub and open in iBooks. 
Compare its appearance with the original. 

Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=196 
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Tutorial 5 • ePub from 
PressBooks 

RICHARD ADAMS 

PressBooks (https://pressbooks.com) is an authoring platform 

that can export eBooks in PDF, EPUB, and MOBI (Amazon) 

formats. PressBooks is a plugin for the WordPress content-

management and web site development system. The Ryerson 

Library maintains a PressBooks installation at 

http://pressbooks.library.ryerson.ca.WordPress and PressBooks 

both enable users to write content in “Visual” (preview) and 

“Text” (HTML code) views, switchable with tabs at the top right 

of the document. Users can also upload images, videos, and 

audio for insertion into an eBook. 

76



Log In Log In 

1. Log in to http://pressbooks.library.ryerson.ca. 

2. Create your own chapter in the GCM802 book. 

Create an eBook Create an eBook 

1. Paste the text from Tutorial 1 into the Visual tab of 

your chapter. 

2. Style the body text as Paragraph and headings as 

Heading 1. 

3. Upload the photos using the Add Media button. Note 

that you can center them and add a caption in the Edit 

dialog box. 

4. Note that you can switch to the Text tab and see the 

HTML code that PressBooks has applied to your text 

and images. 

EBOOK ON EBOOKS  •   77



Screen capture of PressBooks in Visual view. 

Screen capture of PressBooks in Text view. Note the h1 heading tag that 
was applied to the heading. 
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Export to .epub Export to .epub 

1. When finished editing your eBook, go to the Export 

tab and export .epub. 

2. Open the ePub in iBooks and check its appearance. 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=203 
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Tutorial 6 • Apple Pages, 
Amazon Kindle Create, and 
Adobe PDF 

RICHARD ADAMS 

Apple Pages Apple Pages 

As eBooks gained popularity in 2010, Apple took advantage of 

the iPad’s color display and processing power by releasing an 

eBook format called iBooks and creating the iBooks Store. An 

authoring program, iBooks Author, adapted from Pages, made 

it easy for authors to include sophisticated media—including 

photo galleries, panoramic views, 3D objects, animations, and 

videos. iBooks Author saved files as type .iba (iBooks Author) 

and exported to the .ibooks format, a type of ePub with 

additional proprietary coding. The market for sophisticated 

media in eBooks was not as great as Apple had thought, so ten 
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years later they discontinued support of iBooks Author and the 

iBooks format. Today Pages exports to ePub but does not have 

InDesign’s sophisticated controls for image size and placement. 

Making an ePub in Apple Pages 

Apple Pages can be used to make both reflowable and fixed-

layout ePubs. The program supports a variety of media, 

including photos, audio, video, and embedded video. As of the 

2021 version, it no longer supports animation or 3D objects. 

Hopefully Apple will update Pages to include the variety of 

media supported by iBooks author, including 3D objects in .dae 

(Google Collada) format, image galleries, panoramic views, and 

360° views of rotatable objects. 

a. Save your text in a Word .doc or .docx file 

and open in Pages. 

b. Create the cover in Illustrator, Photoshop, 

or InDesign and save as JPEG. 

c. Use the Body style for text, Heading for 

headings, and choose font, font size, and 

font color as desired, and update the styles. 

d. To set up a table of contents, go to View > 

Table of Contents > Edit and select the 

heading style(s) to be included. 

e. Drag-and-drop text-wrapped images into 

the text, set size, and in the Format panel 

select Arrange and choose the type of text 

wrap and spacing. Note that images can be 
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anchored to the text or to the page. 

f. Drag-and-drop full-width images into the 

text, set to the width of the margins. 

g. Export to to ePub by selecting File > Export 

To > EPUB, choose the cover image, select 

Reflowable or Fixed-Layout, and click 

Advanced Options > Use Table of Contents. 

h. View your ePub in iBooks or other 

program. 

Styles palette in Pages 
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Table of Contents palette in Pages 

 

Arrange Image palette in Pages 
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Design Features in Pages 

Feature Description Screen cap 

Headings Define text 
with the 
Heading ¶ 
style, redefine 
font, size, and 
color as 
desired 
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TOC View > TOC, 
click Edit to 
add ¶ Styles, 
check TOC on 
export 

Full-width 
image 

Drag-and-drop 
image into 
text, set width 
to margins, 
add border if 
desired, set 
Arrange to 
Above and 
Below 

Text-wrap 
image 

Drag-and-drop 
image into 
text, set width, 
set Arrange to 
Around. Note: 
Text can wrap 
to transparent 
PNGs. 

Drop-cap Set Style > 
Check Drop 
Cap, define 
lines, color, 
background 
shape if 
desired. 
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Ornament 

Create ¶ Style 
for ornament, 
centered, 
ornament font, 
larger font 
size 

Sidebar 

Set font, size, 
left and right 
indent, border, 
offset 
(“padding”) 

Callout 

Similar to 
Sidebar but 
usually 
without border 

Amazon Kindle and Kindle Create Amazon Kindle and Kindle Create 

Its dominating market share has allowed Amazon to take 

advantage of the eBooks market. The Amazon Kindle is a series 

of low-cost eBook readers that support Amazon’s Kindle 

Package Format (.kpf), along with .epub, .mobi, .pdf, and .html. 

Amazon’s eBooks are sold in Kindle package format (.kpf). 

Epub and other eBook formats can be converted to .kpf using 

online conversion sites, or preferably by writing the eBook in 

Amazon’s Kindle Create app (Mac/Win). 

Kindle Create 

Kindle Create is a simple page layout program for creating 

Kindle Publishing Format (.kpf) files. KPF files can be read on 

Amazon Kindle devices and on iOS/Android and Mac/Windows 

with the Kindle App. Kindle Create has limited text and image 
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formatting controls that coincide with the relative simplicity of 

the Kindle eReaders. 

Page in Amazon Kindle Create, Amazon’s page layout program for 
creating Kindle eBooks. 

Making a Kindle File in Kindle Create 

1. Download Kindle Create (Mac/Win, search for 

“download amazon kindle create”). 

2. Place the text you want to set in Word, e.g., copy 2–3 

chapters of a classic book from The Gutenberg 

Project. (Be sure to avoid text with paragraph returns 

at the end of each line.) 

3. Open Kindle Create and select Create New > Choose 

File (.doc, docx) > browse to the Word document and 

open. 

4. Note that Kindle Create has relatively few formatting 
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options: Theme and Elements on Page (Chapter Title, 

Chapter Subtitle, Chapter First Paragraph). Chapter 

First Paragraph has the option to add a drop-cap. 

Several other Standard Elements are available in the 

menu. 

5. Set the chapter titles as Elements on Page > 

CHAPTER TITLE. 

6. In the Table of Contents palette at left, add the 

chapter titles to the table of contents. 

Adding Images 

1. With the Insert menu at left, Kindle Create can add 

two types of images: 

• Chapter Start Image—a banner across the top of the 

title page 

• Image—includes full-width images, or fractional 

width that can be inline or with text wrap. Images can 

be set to small, medium, large, or full size. 

2. Captions cannot be written in Kindle Create. 
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Kindle Create Table of Contents. 

Kindle Create Insert Image. Chapter Start Image 
inserts a banner image across the top of the chapter 
first page. 
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Sample interactive PDF with 
navigation buttons (bottom right) 
for previous page, home (first 
page), and next page. 

Preview 

1. While formatting your text and image, you can 

preview how the eBook will look on a Kindle (B&W 

or color) using the Preview button. 

Adobe PDF Adobe PDF 

Adobe’s Portable 

Document Format (PDF) is 

the result of Adobe cofounder 

Dr. John Warnock’s idea of 

creating a document format 

that anyone could create and 

read, independent of the 

platform, fonts, and software 

used to create it. PDF is a 

non-reflowable format that 

transitions from print layouts 

to electronic media. 

Interactive PDFs can contain 

interactive tables of contents, 

indexes, navigation buttons, 

and forms. Common uses of 

PDFs are instruction manuals, user guides, and other 
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Making an interactive table of 
contents for a PDF. 

documentation. These may have been created originally for print 

layouts to enclose in packages, and the manufacturer also wants 

to include them on its web site. 

Features of Interactive PDF eBooks 

Two useful features of interactive PDFs are interactive tables 

of contents (TOC) and navigation buttons. When users click 

on interactive TOC entries, they are taken to the page with the 

respective title. Navigation buttons usually include next page, 

previous page, and first page, and could also include buttons for 

the TOC and index. 

Creating an Interactive TOC 

1. To create an 

interactive TOC, 

headings to be 

included should be 

in a heading 

paragraph style, 

e.g., h1. 

2. Open the Layout > Table of Contents and designate 

h1 to be included in the TOC. 

3. Check “Create PDF Bookmarks” 

4. Click OK to create a TOC and place it in the 

Clipboard. The TOC will include all text in the h1 

style and the page on which it occurs. 

5. Click on the page where you want to start the TOC. 
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6. When the InDesign document is exported to PDF, the 

TOC entries will become links that users can click 

and navigate to the respective page. 

Creating Navigation Buttons 

1. Navigation buttons placed on the master page will be 

copied to subsidiary pages. To create navigation 

buttons going to the next page, previous page, and 

home, first draw or place an icon, such as a forward 

arrow, on the master page. Items on the master page 

will be copied to all subsidiary pages. (To delete an 

unwanted master page item from a page, 

CMD+SHIFT+click on the item and then press 

Delete.) 

2. Open the Window > Interactive > Buttons and Forms 

palette. Click on the forward arrow icon and select 

Type: Button; Name: (name the button); Event: On 

Release or Tap; and add an Action “Go to Next 

Page.” 

3. Other actions include Previous Page, First Page, 

Destination, etc. 
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Interactive navigation buttons placed on the master 
page (“A-Master”) will be copied to subsidiary pages, 
which saves placing the buttons on each page and 
programming them. 

InDesign actions for buttons. 
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Tutorial 7 • Animation 

RICHARD ADAMS 

Animation in eBooks generally refers to vector graphics, with 

their small file sizes and scalability. These can add interactivity 

to an eBook, provided they are not overdone to the point of being 

distracting. Animation is most appropriate for colour eBooks 

(i.e., ePub and iBooks) that are designed to read on colour 

tablets. 

eBook animations generally include three types, i.e., you want 

to: 

• make an object, like a vehicle graphic, move when 

the page loads, when touched, or when a button is 

pressed 

• make a graphic, such as an animal or object, jiggle or 

shake when pressed 

• illustrate a complex mechanical movement, such as 
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for a technical book 

Diagram showing HTML tags for a sample animation done with CSS 
and JavaScript 

Animation Type 

Document InDesign Hype jQuery CSS 

ePub FXL ? ︎ N/C ? ︎ ? ︎ 

Mobi N/C N/C N/C N/C 

iBooks N/C ? ︎ easy ? ︎ difficult ? ︎ difficult 

N/C = not compatible 

CSS CSS 

CSS animation is simple to implement but can only animate 

the object in question, like the car above. If you want to have 

a button start the animation or otherwise have user control, 

you would have to use JavaScript to connect the button with 
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the object. For CSS animation the object must have position: 

absolute; or position: relative;. You can control the left and top 

coordinates, along with other styles like size (width, height), 

color, opacity, and rotation. 

To make a CSS animation you will need (1) a named 

@keyframes rule specifying the change points in the animation 

as percents of the timeline, and (2) a tag, ID, or class connecting 

to the @keyframes rule with the “animation-name” style, 

“animation-duration” in seconds (s), and other styles. 

Users can start a CSS animation by touching or clicking on it if 

the “animation-play-state” is set to “paused” by default and set 

to “running” using a :hover or :active pseudoselector. 

CSS Styles for Animations 

rotate transform: rotate(0deg); 

flip horizontal transform: scale(-1); 

.car { 

animation-name: letsgo; 

animation-duration: 3s; 

animation-fill-mode: forwards; 

animation-iteration-count: 1; 

position: absolute; 
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} @keyframes letsgo { 

0% {left: 100px;} 

100% {left: 700px;} 

} 

jQuery jQuery 

The best way to implement user interaction in an animation 

is to use jQuery, an opensource library of JavaScript functions 

that was started by a group of MIT computer scientists. To use 

jQuery you have to load the jQuery library (jquery-3.3.1.min.js) 

and the jQuery user interface (UI, jquery-ui.js). jQuery uses the 

class assigned to the button and the object to link the two. jQuery 

is somewhat technical but is supported by ePub. 

$(function() { 

$(‘start’).click(function() { 

$(‘car’).animate({left: ‘+=1200px’}, 1000); 

}); 

}); 

In this example, we are animating the left coordinate of the “car” 

class by adding 1200px to the current value, which moves it off 

the screen, and doing the animation in 1000 microsec., or 1 sec. 
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The animation is triggered when the user clicks the button, class 

‘start.’ 

InDesign InDesign 

InDesign animations can be created using the Window > 

Interactive > Buttons and > Animation panels: 
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1. Use the Interactive > Animation panel to animate the “car.png” 
graphic to “Move Right,” then adjust the distance using the green 
motion guide. 

2. Use the Interactive > Buttons and Forms panel to make the “Go!” 
shape into a button that plays the “car
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Tumult Hype Tumult Hype 

Tumult Hype (www.tumult.com/hype) is a vector-graphic 

animation program for MacOS similar to Adobe’s Flash and 

Animate. Hype has an easy-to-use interface and simple 

procedure for placing an animation into a web page or iBook. 

The publisher offers a fully functional demo for 14 days. 

Screen capture of an animation in Tumult Hype. (Car from 
pngtree.com.) 
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Components in Tumult Hype 

Component Function 

1 stage document or pasteboard for the animation 

2 layers and 
properties 

each object goes on a separate layer and is 
affected by CSS properties in the list 

3 timeline 
with playhead controls timing of the animation 

4 keyframes main points of change in the animation 

5 tweens transitions between keyframes 

New Document New Document 

1. Make a new document in Hype. Set the stage size to 

the width and height of the background image 

(864324px). 

2. Drag-and-drop the background image onto the stage. 

3. Drag-and-drop the car image onto the “road,” size 

appropriately, and place at the left edge of the scene. 

4. With the Elements, draw a rectangle with coloured 

circles that will be made into buttons. 
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Animation Animation 

1. The animation sequence in Hype is: timeline > 

keyframe > position. To animate the car, first select it. 

Put the Play Head at 00:00.00 sec. and place a 

Keyframe for the Origin (Left) Property at that point. 

2. Move the timeline to 2 sec. (or the length of time you 

want the car to take to get off the screen) and place 

another Keyframe > Origin (Left) at that time. 

3. Move the car to the right, off the stage. 

4. Play the animation in Hype to see how it works. 

Buttons Buttons 

1. To give users control over the animation, select the 

green circle that you drew. In the Actions Inspector at 

right (hand symbol), click on On Mouse Up (Touch 

End) > Action > Continue Timeline. 

2. To keep the animation from starting by itself, bring 

the Play Head to the 00:00.00 position. Set Timeline 

Actions > Action > Pause Timeline. 

3. To test your animation, click the Preview button, 

which will open it in the browser of your choice. 

Check that the button works and that the animation 

plays as expected. 
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Additional Steps Additional Steps 

1. To make the car turn around at the end of the 

animation, add a Keyframe for Rotation Angle (Y) 

and set to 180°. 

2. Add another Timeline Action > Pause Keyframe to 

make the animation stop before the car turns around. 

3. Add more seconds to the timeline to make the car 

drive back to the starting point and turn around again. 

4. Program a second button to bring the car back. 

Export Animation Export Animation 

A Hype animation can be placed into an Apple iBook by 

exporting to Apple Widget (.wdgt) format. Just drag-and-drop 

the .wdgt file into iBooks Author. 

The animation can be placed into a fixed-layout ePub by 

exporting as Animated GIF, however this format offers no user 

control. 
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Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=217 
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Tutorial 8 • Video Editing with 
iMovie 

RICHARD ADAMS 

iMovie is a free editing program for Mac OS and is available 

on the App Store. The program provides an easy-to-use interface 

for editing videos—deleting parts of the video, adding titles and 

transitions, deleting audio, and adding voiceovers. 
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Key Functions in iMovie 

Component Function 

trim clip Modify > Split Clip 

fade from/to black Transitions > Fade to Black (“From” at beginning) 

title Titles > choose format (start on black or on video) 

speed up/slow down Modify > Fast Forward or Modify > Slow Motion 

save File > Share > File 

Recording Video Recording Video 

Record a video with a DSLR camera set to video or with a 

smartphone. For ePub 720-pixel resolution should be adequate. 

Save the video clip to disk. 

Editing Editing 

1. Open iMovie, import your clip, and drag it to the 

editing area. 

2. To delete parts of your clip that you don’t want, move 

the Playhead to the place you want to trim the video 

and select Modify > Split Clip. Then select the 

unwanted portion and delete. 
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3. Add a Fade from Black at the beginning and Fade to 

Black at the end (both are called “Fade to Black”). 

4. Add a title by choosing one from the Title Gallery. 

The title can start on the Fade from Black or on the 

video itself. 

5. iMovie can crop videos, but the original aspect ratio 

(height to width) must be maintained. 

Edited video in iMovie showing effects applied. 
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Reflowable ePub with video 

Voiceover Voiceover 

1. To add narration (voiceover), record the narration in 

Apple QuickTime Player (File > New Audio 

Recording) and save to disk. 

2. Drag the audio recording file into the movie and place 

underneath the clip where you want it to start. 

3. If you want to remove the existing sound, select the 

clip, choose Modify > Detach Audio, and then select 

and delete the audio portion. 
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Export Export 

To save your movie for inclusion in your ePub or iBook, select 

File > Share > File. Choose the quality level that you want. 

Place Place 

1. To place your video in a fixed-layout or reflowable 

ePub, place the video file on its own page in the 

InDesign file and then export to ePub. 

2. To place in an iBook, drag-and-drop the video file 

into an iBooks Author page. 

Instructional Video Instructional Video 

A YouTube element has been excluded from this 
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version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=230 
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Tutorial 9 • Excel Business 
Functions 

RICHARD ADAMS 

This tutorial explains some of the Excel functions identified by 

Ben Dugas, product manager at eBook publisher Rakuten Kobo, 

during a guest lecture he presented in the 2018 summer eBooks 

class. 

CONCATENATE CONCATENATE 

The CONCATENATE function combines two or more columns 

into one. Text (including spaces) goes in quotes and is separated 

from variables by “&,” e.g., “=CONCATENATE(B3&” 

“&A3”). 
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SORT SORT 

The SORT function (Data > Sort) can be used to order 

spreadsheet entries alphabetically or numerically. 

VLOOKUP VLOOKUP 

The VLOOKUP function provides a way to look up data in 

an Excel table. VLOOKUP can be combined with ActiveX 

interactive objects to create dynamic lookups. 

1. Open the file, “vlookup.xlsx.” Note that the file 

contains a list of sales representatives and their 

annual sales. 

2. To the right of the last column, in cell G2, create a 

field called “ID” and to the right of that, in cell H2, 

set the first value to “1.” 

3. Below the “ID” and “1” cells, in cell G3, create 

another field, “Sales,” and to the right of that, in cell 

H3, insert an “=VLOOKUP” function, which has 4 

arguments: 

◦ cell containing the desired value (H2) 

◦ cells containing the data range (B3:E9) 
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◦ column in the range with the desired data to 

report (4) 

◦ whether an approximate match is 

acceptable to the desired value (FALSE) 

4. The function should read 

=VLOOKUP(H2,B3:E9,4,FALSE) 

5. Note that Excel reports the sales volume for Sales 

Representative #1. 

6. To make an interactive VLOOKUP, turn on the 

Developer Tab in Excel (Preferences > View > 

Developer Tab). 

7. Insert a “Spinner” (up/down arrow) to the right of the 

VLOOKUP fields. 

8. Right-click the Spinner and set Format Control to 

Cell Link H2. Also set the appropriate Minimum and 

Maximum values. 

9. Click on another cell. Note that the Spinner will 

increase or decrease the lookup value in Cell H2. 

PivotTables PivotTables 

PivotTables (Insert > PivotTable) are a powerful tool for creating 
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summaries from large amounts of data that would otherwise be 

too vast to interpret. 

1. Open the file “pivot-table.xlsx.” Note that Sheet 1 

contains 214 rows of sales figures for fruits and 

vegetables by country and date—lots to digest! 

2. Create a pivot table that lists the total amount of each 

fruit exported by all countries. 

3. Place the cursor on the first cell of the table. 

4. Select Insert > PivotTable, click button for Table or 

Range. When you put the cursor in the field Table/

Range, Excel selects the entire table for the input and 

asks you where to put the table. Select a cell to the 

right of the table. Note that a PivotTable object 

appears, along with a sidebar of PivotTable Fields. 

5. In the sidebar, rearrange the Field Names as shown in 

the screen capture below, i.e., Filters: Country; Rows: 

Product; Values: Sum of Amount. 

6. Note that the PivotTable is dynamic—the dropdown 

arrow in the PivotTable can be used to select the 

country for the report. 
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Instructional Video Instructional Video 

A YouTube element has been excluded from this 
version of the text. You can view it online here: 
https://pressbooks.library.ryerson.ca/ebooks/?p=336 
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Tutorial 10 • Online Portfolio 

RICHARD ADAMS 

An online portfolio is a good way to catalog and publicize your 

eBooks from one location. The graphic below shows the HTML 

tags and CSS styles used to make the sample portfolio. 

The portfolio can contain links to online eBook files, such as 

Ryerson’s Pressbooks publishing platform, or to actual eBook 

files that you place on your server. 

Procedure Procedure 

To make the portfolio: 

1. Save thumbnail-sized JPG or PNG images of your 

eBook covers. The size used here is 464×696px 

which were sized to 50% or 232×348px in 

Dreamweaver. These covers were designed in Adobe 

117



Illustrator and exported with the File > Export for 

Web dialog box, which enables the final resolution to 

be set and previewed. 

2. The web page is a fixed-size page of 1228px wide by 

921px high and with a light grey (“whitesmoke”) 

background. 

3. Inside the “page” is an invisible <div> grouping tag 

labeled with the ID “flexbox,” 1228px wide, that uses 

the “flexible box [New Window]” layout (for the 

illustration, the <div> tag was outlined with a dashed 

border to make it visible). The flexbox layout enables 

you to add more thumbnails that will arrange 

themselves in order on the page, depending upon their 

number and size. 

4. Each <img> tag with its thumbnail is grouped with its 

caption <figcaption> using a <figure> grouping tag, 

as shown at the middle right of the diagram. This 

enables you to put a brief description under each 

thumbnail. 

5. All the <img> tags are linked using <a href> tags to 

their respective eBooks on the Ryerson Library’s 

Pressbooks system. You could also place .epub and 

other files on your server and link to the files so that 

readers could download the them. The tags are set to 

open in new tabs or windows so readers do not have 

to leave the catalog page. 
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Part 3 • Student 
Contributions 

Purpose Purpose 

This chapter is for students in the summer 2019 GCM 802 

class to add summaries of their “Hot Topics” and “Cool Tech” 

discussions. Please note that the Ryerson Library publishes 

eBooks with a Creative Commons “Share and Share Alike with 

Attribution” (CC-BY) open-source copyright license, meaning 

others can reuse and edit the work, as long as they attribute the 

original author. For this reason, the Library is very strict about 

ensuring that they have the right to reproduce written work and 

accompanying graphics under this license. 

When adding graphics from other sources (i.e., photos that you 

did not take yourself), please make sure that we have the right 

to reproduce the graphic under the CC-BY license. For example, 

photos from Google Images [New Window] may be copyrighted, 

while those from Pixabay.com [New Window] have an open 
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license. Also Adobe gives a blanket license to reproduce screen 

captures from its programs, provided that the screen capture 

is attributed to Adobe and that the dialog box or menu is not 

cropped. 
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Accessible Design 

LOREN AMARAL 

Contributed by Loren Amaral, GCM ’21 

In a time where inclusion is more prominent than ever, it’s 

important that we do our part as creatives to inform ourselves 

and promote the use of accessible design. Accessible design 

can be seen in every industry from automotive, to design, and 

retail, to name a few. Within each of these industries, if each 

designer is practising accessible design, then they are ultimately 

learning to improve their target market’s user experience. Before 

we begin, it is highly recommended that you look into certifying 

yourself with The Accessibility for Ontarians with Disabilities 

Act (AODA) [New Window] course, in order to learn more 

about accessibility and how you can introduce it to your own 

processes. 
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What is it? What is it? 

In order to define “Accessible Design” we must first look at 

three concepts pertinent to this topic: 

1. Accessible Design: is the process in which the needs 

of people with disabilities are specifically considered. 

◦ Example: If a medical clinic recognizes that 

their clients are primarily older and have a 

difficult time navigating their front steps, 

they should consider accessible design by 

investing in a ramp or elevator. 

2. Universal Design: is a broader concept, in which the 

design of products and environments are usable by all 

people, to the greatest extent, without the need for 

specialized design. 

◦ Example: Doors, curbsides, and windows 

are examples of accessible design that 

allow for users such as baby strollers, 

delivery workers, and people with 

disabilities. 

3. Usable Design: is a form of testing within the design 

process. It is defined as the “effectiveness, efficiency, 

and satisfaction” process. This is when engineers test 

their designs through user experiences to further learn 

and improve operational functions. 

◦ Examples: Surveys, reviews, user stories, 
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etc. 

Now that we’ve reviewed these concepts, we can better define 

accessible design as “The combination of the technical and the 

user experience (UX).” 

Accessible Product Design Accessible Product Design 

This is a relatively recent invention called a Timer Cap, which 

allows users to set a timer on their pill bottles. This is useful for 

those that are forgetful, or for those that can’t open consume pills 

until a specific time. 
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TimerCap® has a built-in timer that counts the time since it was last 
opened. (Courtesy of Amazon.ca) 

Users Users 

Accessible Design would not be possible without recognizing its 

users, and more specifically, people with disabilities. In Ontario 

alone, 15% of our population has been diagnosed with some 

form of disability. These disabilities take a wide variety of 

forms, ranging from mobile to emotional, and are most 

prominent in those age 75 and older. One perspective to consider 
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when designing: Ask yourself, “Will I be able to read this when 

I’m 75?” 

Print vs. Digital Accessibility in Publishing Print vs. Digital Accessibility in Publishing 

Ultimately there are plenty of amazing things about the print 

industry and the tactile experience it offers users. Below is an 

example of accessible print design, in which a milk company 

has added bold labels and a 3D braille finishing to their cartons, 

allowing visually-impaired users to identify the products. 

Braille milk packaging. (Courtesy of Ateriet.) 

While there are many accessibility print solutions, it is apparent 

that electronic publications offer a different form of accessible 

aid. Electronic publications offer a solution by those bound by 

“Print Disabilities” which can be effects of blindness, low-

vision, dyslexia, mobility impairment, etc. Statistically, 1 in 8 

people struggle to read conventional print, so when only 5% of 
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eBooks are made in an accessible format, this makes it difficult 

for “print disabled” users to read. 

This is why more suitable format should be available such as 

eBooks, audible readers, podcasts, etc. There are many added 

benefits and features that make these mediums accessible to 

users such as; text-to-speech, changing font size and colour, 

reading in braille and bookmark navigation. 

There are many added benefits when considering accessibility 

in design. The first benefit is that websites are proven to be 

easier and cheaper to maintain, and they actually rank higher in 

search engines. Another added benefit is that the more accessible 

you are, the more users will be able to experience your designs 

and offer feedback to further improve. The con associated with 

accessibility in design is that creative options are limited, as 

there must be strict quality control in order to ensure a standard 

across all platforms. 

Accessible Design Tips Accessible Design Tips 

• Contrast Contrast 

It’s important that there is a clear distinction between 

the background and foreground within the design. It’s 

very trendy to see these low contrast designs such as 

KKW or Kylie Skin, but it’s not ideal for accessibility. 

Based on accessibility guidelines, the contrast 

percentage depends on the foreground object and size. 

They state that normal text should have a 4.5:1 ratio, 
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whereas larger text (14pt +) should have a 3:1 ratio. 

A11Y Color Contrast Validator [New Window] allows 

you to upload images or input colour values to check 

whether your colour palette is accessible by industry 

standards. 

• Typography Typography 

The next tip is typography, which plays a huge role in 

accessible design. To start, when choosing the size of 

the type, it is advised to stay above 12pt and to have 

the capability to size the type by 200% if required. 

When looking at typeface families, try to stay away 

from decorative typefaces as they can be difficult to 

read. It is also advised that for readability purposes, 

to use serif fonts for print work, and sans-serif fonts 

for online work. The font Open Dyslexic [New 

Window] was designed to help those with dyslexia 

read large amounts of text. 

OpenDyslexic Font 

Lorem ipsum dolor sit amet, consectetur 
adipiscing elit, sed do eiusmod tempor 
incididunt ut labore et dolore magna aliqua. Ut 
enim ad minim veniam, quis nostrud 
exercitation ullamco laboris nisi ut aliquip ex 
ea commodo consequat. 
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• Hierarchy and TOC Hierarchy and TOC 

This is a great tool to know if you’re making 

accessible documents or working with Adobe Acrobat 

for instance. Most applications allow you to make 

some type of interactive TOC by using Paragraph 

Styles to organize the document and making 

accessible for e-readers. Attached is a link on how 

to use paragraph styles [New Window] and the 

Interactive TOC tool in InDesign [New Window], just 

in case you need a refresher. As well, in the Adobe 

Acrobat program, there’s a great accessible tool that 

allows you to organize the text and images throughout 

the document so that e-readers can accurately 

translate. 

• Imagery Imagery 

The final tip is related to imagery and graphics. 

Opacity and sizing are pretty general rules to follow, 

making sure it’s visible to users as best as possible. 

Alt-tags are also really important for e-readers to 

translate the document properly by describing images 

and graphics. Image Captions are also a great way to 

make images accessible. 
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SourcesSources  

• https://www.washington.edu/doit/what-difference-

between-accessible-usable-and-universal-

design#header 

• https://www.marsdd.com/wp-content/uploads/2014/

01/Towards-an-Accessible-Future-Ontario-

Innovators-in-Accessibility-and-Universal-

Design1.pdf 

• https://www.oreilly.com/library/view/accessible-

epub-3/9781449329297/ 

• http://epubsecrets.com/producing-accessible-

ebooks.php 

• https://www.rnib.org.uk/information-everyday-living-

reading-ebooks-and-digital/accessibility-ebooks 
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Appendix • Image Credits 

“Adobe® Photoshop®, InDesign®, and Dreamweaver® 

screenshots reprinted with permission from Adobe Systems 

Incorporated. Adobe® and Photoshop®, InDesign®, and 

Dreamweaver® are either registered trademarks or trademarks 

of Adobe Systems Incorporated in the United States and/or other 

countries. Screen captures cannot be cropped further.” 

Chapter 1 

Reflowable eBook on an Amazon Kindle B&W eReader by 

Frank Holleman on Unsplash.com. 

Cookbook content suitable for ePub-FXL, courtesy of Instant 

Pot Eats on Google Images. 

Chapter 4 

Car image courtesy of pngtree.com. 

Tutorial 2 

Books with plant photo by Fang Wei Lin on Unsplash.com. 
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Tutorial 7 

Green car caricature courtesy of PNGTree.com. 

Accessible Design 

TimerCap photo courtesy of Amazon.ca. 

Milk carton photo courtesy of Ateriet. 
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